Cloudflare with cyberpanel

Hi, i recently bought a vps and installed cyberpanel and migrated from godaddy to cyberpanel i followed this tutorial to add nameserver in cyberpanel https://blog.cyberpanel.net/2018/02/24/how-to-register-private-name-servers-on-namecheap-or-godaddy-with-cyberpanel/

now my old site already had cloudflare and was configured in godaddy's nameserver since i had to create a private namerserver for cyberpanel so i want to know how to add cloudflare to cyberpanel?
or can i use my old nameserver of cloudflare in cyberpanel if yes then kindly tell me how :)

Comments

  • Creating private name servers with CyberPanel is not a must, you only need to create private nameservers if you are planning to run DNS on your CyberPanel server too.

    Otherwise, if you are going to use CloudFlare for DNS, then you don't need to do anything on CyberPanel side. Just set up your domain on CloudFlare and add A record pointing to your CyberPanel server.
  • > @CyberPanel said:
    > Creating private name servers with CyberPanel is not a must, you only need to create private nameservers if you are planning to run DNS on your CyberPanel server too.
    >
    > Otherwise, if you are going to use CloudFlare for DNS, then you don't need to do anything on CyberPanel side. Just set up your domain on CloudFlare and add A record pointing to your CyberPanel server.

    Thank you for replying... I am sorry I couldn't understand what you are saying I am new to this stuff... I want to use my domain with cyberpanel my domain registration is GoDaddy so I created a nameserver for cyberpanel which I shouldn't have... So what I understand from your reply is i set up the nameserver to cloudflare in GoDaddy and through cloudflare I add a record pointing to my cyberpanel? But I don't know how to do it...if I did it then So I don't have to add anything in cyberpanel like nameserver or dns?
  • Correct for better understanding you can use this guide as a starting point: https://www.cyberpersons.com/2016/08/08/setup-cloudflare-domain/
  • edited August 4

    Correct for better understanding you can use this guide as a starting point: https://www.cyberpersons.com/2016/08/08/setup-cloudflare-domain/

    thanks a lot sir i did as you said and everything worked well. after uploading my database i am getting this error when i try to visit my website

    This page isn’t working
    www.website.com redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    and when trying to view my website with https:// i m getting cloudflare 502 error

    kindly help me :)

    update: it happens in chrome but in mozilla and in mobile android browser my website is opening but the homepage is like as if i installed new wordpress... whereas my homepage should show my theme along with my posts
  • paste your rewrite rules.
  • edited August 4

    paste your rewrite rules.

    # BEGIN LSCACHE
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##

    RewriteEngine on
    CacheLookup on
    RewriteRule .* - [E=Cache-Control:no-autoflush]
    RewriteRule ^min/\w+\.(css|js) - [E=cache-control:no-vary]

    ### marker CACHE RESOURCE start ###
    RewriteRule wp-content/.*/[^/]*(responsive|css|js|dynamic|loader|fonts)\.php - [E=cache-control:max-age=3600]
    ### marker CACHE RESOURCE end ###

    ### marker LOGIN COOKIE start ###
    RewriteRule .? - [E="Cache-Vary:wp-postpass_7fe101fbda08d0676a2b510e2a583086"]
    ### marker LOGIN COOKIE end ###

    ### marker FAVICON start ###
    RewriteRule favicon\.ico$ - [E=cache-control:max-age=86400]
    ### marker FAVICON end ###


    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    # END LSCACHE
    # BEGIN NON_LSCACHE
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    ### marker MINIFY start ###

    RewriteEngine on
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} ^(.*)/min/(\w+)\.(css|js)$
    RewriteCond %1/wp-content/cache/$2/$1.$2 -f
    RewriteRule min/(\w+)\.(css|js) wp-content/cache/$2/$1.$2 [L]

    ### marker MINIFY end ###

    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    # END NON_LSCACHE

    # BEGIN WordPress

    # END WordPress



    and the litespeed plugin is not showing in wp dashboard
  • Since your issue has changed please create seprate thread, but I believe you have not transferred your site correctly.

    Also turn off CloudFlare proxy until you are sure that site is moved successfully.
  • Since your issue has changed please create seprate thread, but I believe you have not transferred your site correctly.



    Also turn off CloudFlare proxy until you are sure that site is moved successfully.

    fixed by adding this rule in htaccess

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]


    # END WordPress
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion