Error While Installing Discourse On CyberPanel — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Error While Installing Discourse On CyberPanel

I am following this tutorial to install https://cyberpanel.net/blog/2019/02/22/how-to-install-nextcloud-on-cyberpanel-with-docker/

discourse but after attempting all steps I am getting 503 service unavailble error

I used latest image of docker..

I think I misconfigured while following this steps https://cyberpanel.net/blog/2019/02/12/reverse-proxy-traffic-to-docker-container-on-cyberpanel/

because I dont find this code in conf
extprocessor dockerbackend {
type proxy
address 127.0.0.1:8080
maxConns 100
pcKeepAliveTimeout 60
initTimeout 60
retryTimeout 0
respBuffer 0
}

so I added this code in conf because I dont find any where to add my port

please help me
Tagged:
Tagged:

Comments

  • When I remove this code from rewritable rules

    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]

    & also

    extprocessor dockerbackend {
    type proxy
    address 127.0.0.1:8080
    maxConns 100
    pcKeepAliveTimeout 60
    initTimeout 60
    retryTimeout 0
    respBuffer 0

    I am getting normal cyberpanel installed page
  • Guyz anyone can point me atleast in right direction
  • If you read the article you mentioned in your post carefully, it is already explained.

    extprocessor dockerbackend {
    type proxy
    address 127.0.0.1:8080
    maxConns 100
    pcKeepAliveTimeout 60
    initTimeout 60
    retryTimeout 0
    respBuffer 0
    }

    This should go in /usr/local/lsws/conf/httpd_config.conf

    And rewrite rules in Rewrite Rules tab

    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]

    All you need to do is read each step in that guide extremely carefully.
  • Type your comment> @usmannasir said:
    > If you read the article you mentioned in your post carefully, it is already explained.
    >
    > extprocessor dockerbackend {
    > type proxy
    > address 127.0.0.1:8080
    > maxConns 100
    > pcKeepAliveTimeout 60
    > initTimeout 60
    > retryTimeout 0
    > respBuffer 0
    > }
    >
    > This should go in /usr/local/lsws/conf/httpd_config.conf
    >
    > And rewrite rules in Rewrite Rules tab
    >
    > RewriteCond %{HTTPS} !=on
    > RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    > REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]
    >
    > All you need to do is read each step in that guide extremely carefully.

    Thanks for reply
    today i did each step carefully but still i am getting 503 service unavailable error

    i did indeed change port to 9000..but still getting error..help me with this
  • heres log

    discourse 08:44:28.05 
    discourse 08:44:28.06 Welcome to the Bitnami discourse container
    discourse 08:44:28.06 Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-discourse
    discourse 08:44:28.06 Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-discourse/issues
    discourse 08:44:28.06 
    discourse 08:44:28.07 INFO  ==> Validating settings in POSTGRESQL_CLIENT_* env vars
    discourse 08:44:28.13 WARN  ==> Hostname postgresql could not be resolved, this could lead to connection issues
    discourse 08:44:28.15 WARN  ==> Hostname redis could not be resolved, this could lead to connection issues
    discourse 08:44:28.15 WARN  ==> The DISCOURSE_DATABASE_PASSWORD environment variable is empty or not set. Set the environment variable ALLOW_EMPTY_PASSWORD=yes to allow a blank password. This is only recommended for development environments.
    discourse 08:44:28.15 WARN  ==> The DISCOURSE_REDIS_PASSWORD environment variable is empty or not set. Set the environment variable ALLOW_EMPTY_PASSWORD=yes to allow a blank password. This is only recommended for development environments.
    discourse 08:44:28.16 INFO  ==> Creating Discourse configuration file
    discourse 08:44:28.20 INFO  ==> Ensuring Discourse directories exist
    discourse 08:44:28.22 INFO  ==> Trying to connect to the database server
    discourse 08:45:28.44 ERROR ==> Could not connect to the database
  • Type your comment> @usmannasir said:
    > If you read the article you mentioned in your post carefully, it is already explained.
    >
    > extprocessor dockerbackend {
    > type proxy
    > address 127.0.0.1:8080
    > maxConns 100
    > pcKeepAliveTimeout 60
    > initTimeout 60
    > retryTimeout 0
    > respBuffer 0
    > }
    >
    > This should go in /usr/local/lsws/conf/httpd_config.conf
    >
    > And rewrite rules in Rewrite Rules tab
    >
    > RewriteCond %{HTTPS} !=on
    > RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    > REWRITERULE ^(.*)$ http://dockerbackend/$1 [P]
    >
    > All you need to do is read each step in that guide extremely carefully.

    I indeed edit conf via ssh and add rewrite rules by going in the panel...but getting error of 503 error

    I know I am just one step behind to get things working..so please help me & point me to right direction
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion