[SOLVED] Trying to import a database via phpmyadmin fails

edited August 6 in Web Server
Hello again ;-)

I'm having great difficulty trying to import databases. I have several sites I am trying to clone to the new CyberPanel installation and the smallest db file I have is 5mb with the largest at 35mb they all fail with the "connection_reset" error

I have adjusted all the memory limits I can find, I have done so via the php config editor with in CyberPanel. When at the import screen of phpmyadmin I show the max file size at 100MiB, this should be sufficient right?

Is there a limit I should be checking elsewhere? When I run an import from a 50K sql file, it works fine.

Also, why don't I see changes to the max limit on the upload when making changes via the php config editor? I have made edits on all the php 7 (7.0, 7.1, 7.2)

I know Chrome can be notorious for chaching issues, so I have also tried this via an incognito window.

Thanks ... Scott

Comments

  • So I made another attempt to edit the php configs by following this ...

    https://docs.cyberpanel.net/doku.php?id=change_upload_limit_for_phpmyadmin

    I was doing this the same way before, with the exception of the server restart. I couldn't remember the command so I went in via the server status link in CyberPanel. There are four services listed as running - OLS, MariaDB, PowerDNS, and PureFTPd - I was restarting OLS via this panel but nothing would update for the memory allocation.

    I changed all the memory limits to 200mb, did a restart via command line of lscpd and presto, the memory limit showed 200MiB and the sql import went through just fine.

    I'm still confused as to why the limit of 100MiB was not sufficient when I couldn't even get a 5mb file to import.


  • Normally the actual allowed import limit is displayed itself in PHPMYAdmin, and I think you were only missing 'systemctl restart lscpd' ?
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!