Unable to detect your OS... — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Unable to detect your OS...

Hello all, I have been facing this complication while trying to install Cyberpanel on my server.
All help and suggestions are welcomed.

Below is my config:

Distributor ID: Ubuntu
Description: Ubuntu 20.10
Release: 20.10
Codename: groovy

Here are the scripts I used
Script 1 -
>>sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)
Script 2 -
>>cd /tmp
>>wget -O installer.sh https://cyberpanel.net/install.sh
>>chmod +x installer.sh
>>sh installer.sh

Here is the error I get each time:

[email protected]:~$ sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1305 100 1305 0 0 16948 0 --:--:-- --:--:-- --:--:-- 17171
-e
Unable to detect your OS...

-e
CyberPanel is supported on Ubuntu 18.04, CentOS 7.x and CloudLinux 7.x...

Comments

  • Ubuntu 20.10 is not supported. Try 20.04 LTS.
    https://ko-fi.com/istiak101
  • bcxbcx
    edited September 15
    Thank you for your response. I used to have UBUNTU 20.04 LTS focal fossil. I never really understood how Linode moved it to 20.10. Also, is it possible to safely downgrade the ubuntu version back to 20.04?
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!