Alias domain SSL not working — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Alias domain SSL not working

edited September 17 in General Discussion
SSL is not working for alias domains, tried with Let's encrypt and ZeroSSL. Somehow OLS is picking certificate from wrong vhost.

I have roundcube running at mail.domain.com and alias domains mail.domain2.com etc.

It did work fine before but at some point after adding new alias domain it stopped working for that single domain. After steps below it's not working for any alias domains.

I have tried deleting and readding the main domain, issued cert from CP to main domain, readded alias domains, issued certs from command line with acme.sh without error. Rebooted server several times. Still not working.

Creating child domain and switching document root gives Error 500.

CP was already version 2.1.1 but ran the upgrade command just in case. Tried also with OLS 1.6.21 and 1.7.14.

Comments

Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion