CyberPanel Installation Error — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

CyberPanel Installation Error

Provider: Oracle Cloud

Virtualization Type: VPS

System: Ubuntu 20.04

Installation option:

OLS or Enterprise?
OLS

Installing from official server or mirror server?
official

Install Memcached extension for PHP?
no

Install LiteSpeed Memcached?
no

Install Memcached?
no

Install Redis extension for PHP?
no

Install Redis?
yes


Problem:

[10.11.2021_16-44-44] [ERROR] We are not able to run apt-get -y install openlitespeed return code: 100. Fatal error, see /var/log/installLogs.txt for full details.

I tried re-install but still happens the same again and again.
Tagged:
Tagged:

Comments

  • I'm facing issue while installation of cyber panel.

    Error is -

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package openlitespeed



    [10.12.2021_15-01-40] ########################################################## ###############

    [10.12.2021_15-01-40] Running apt-get -y install openlitespeed failed. Running a gain, try number 3

    [10.12.2021_15-01-40] ########################################################## ###############




    [10.12.2021_15-01-40] ########################################################## ###############

    [10.12.2021_15-01-40] [ERROR] We are not able to run apt-get -y install openlite speed return code: 100. Fatal error, see /var/log/installLogs.txt for full deta ils.

    [10.12.2021_15-01-40] ########################################################## ###############

    Oops, something went wrong...


    and its stope process ahead.

    please help.
  • I also face pip install --default-timeout=3600 virtualenv==16.7.9 has failed for 49 times
  • in Centos7:

    Collecting decorator==3.4.0
    Using cached decorator-3.4.0.tar.gz (30 kB)
    Preparing metadata (setup.py) ... error
    ERROR: Command errored out with exit status 1:
    command: /usr/local/CyberPanel/bin/python3 -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-ht97s020/decorator_f44e397aec204694b0ef75de5a2cf012/setup.py'"'"'; __file__='"'"'/tmp/pip-install-ht97s020/decorator_f44e397aec204694b0ef75de5a2cf012/setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-k66g2dkq
    cwd: /tmp/pip-install-ht97s020/decorator_f44e397aec204694b0ef75de5a2cf012/
    Complete output (1 lines):
    error in decorator setup command: use_2to3 is invalid.
    ----------------------------------------
    WARNING: Discarding https://files.pythonhosted.org/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz#sha256=c20b404cbb7ee5cebd506688e0114e3cd76f5ce233805a51f36e1a7988d9d783 (from https://pypi.org/simple/decorator/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
    ERROR: Could not find a version that satisfies the requirement decorator==3.4.0 (from versions: 3.3.1, 3.3.2, 3.3.3, 3.4.0, 3.4.2, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.6, 4.0.8, 4.0.9, 4.0.10, 4.0.11, 4.1.0, 4.1.1, 4.1.2, 4.2.1, 4.3.0, 4.3.1, 4.3.2, 4.4.0, 4.4.1, 4.4.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.1.0)
    ERROR: No matching distribution found for decorator==3.4.0

    pip install --default-timeout=3600 -r /usr/local/requirments.txt has failed for 49 times
    Wait for 3 seconds and try again...
  • I have this error on Oracle cloud - Ubuntu 20.04

    (23) Failed writing body
  • I solved my problem using "sudo su - " then run the scrip to install.
    Oracle Cloud - Ubuntu 20.04
  • Type your comment> @lcjunior said:
    > I solved my problem using "sudo su - " then run the scrip to install.
    > Oracle Cloud - Ubuntu 20.04

    I am getting this error in oracle cloud.

    x86_64 system is required...

    which image and shape did you use?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!