Error upgrade to v1.7.1.

After trying to upgrade to v1.7.1 I got this message:
######################################################

You can not upgrade to v1.7.1 via automatic upgrade.

######################################################
Now I can not log in to the panel at:
https: //xx.xx.xx.xx: 8090
It shows me this error:

503 Service Unavailable
The server is temporarily busy, try again later!
How can you fix it to get to CyberPanel?

Comments

  • For now, upgrade does not run for your version, did you tried restarting gunicorn socket?
    systemctl restart gunicorn.socket
  • For now, upgrade does not run for your version, did you tried restarting gunicorn socket?

    systemctl restart gunicorn.socket
    Did not help.
    The update could not be done. When manually updating:
    https://forums.cyberpanel.net/discussion/comment/860#Comment_860
    It completely stopped working.
    In the installer, np was missing /usr/local/CyberCP/bin/.
    The entire Cyberpanel stopped working. There is some error in the update system.
    I have to install everything from scratch.
  • This is fixable you dont need to reinstall. But you should not manually upgrade when its mentioned that this version is not upgradeable.

    Submit the ticket if you want to get this one fixed.
  • CyberPanel has stopped working. After adding the 'bin' directory with the contents, it worked but did not have css.
    I am now installing from the beginning. the updates probably need to be improved.
    A few days ago I asked for github and here for adding polish and how to add translation and updates.
  • edited August 20
    Nencio said:

    CyberPanel has stopped working. After adding the 'bin' directory with the contents, it worked but did not have css.
    I am now installing from the beginning. the updates probably need to be improved.
    A few days ago I asked for github and here for adding polish and how to add translation and updates.

    I will give you the easy version, download this file: https://github.com/usmannasir/cyberpanel/blob/v1.7.1-dev/locale/id/LC_MESSAGES/django.po

    Edit this file via any editor, recommended is poedit. Once done you can send this file via private message or ticket.
  • Nencio said:

    CyberPanel has stopped working. After adding the 'bin' directory with the contents, it worked but did not have css.
    I am now installing from the beginning. the updates probably need to be improved.
    A few days ago I asked for github and here for adding polish and how to add translation and updates.

    I will give you the easy version, download this file: https://github.com/usmannasir/cyberpanel/blob/v1.7.1-dev/locale/id/LC_MESSAGES/django.po

    Edit this file via any editor, recommended is poedit. Once done you can send this file via private message or ticket.
    If I am in 1.7 can I upgrade?
  • Nope..

    [12-25-20-Mon-Aug-2018] #########################################################################

    [12-25-20-Mon-Aug-2018] You can not upgrade to v1.7.1 via automatic upgrade.

    [12-25-20-Mon-Aug-2018] #########################################################################

    so we won't be able to install 1.7.1 why? I was so happy when saw the features
  • Nencio said:

    CyberPanel has stopped working. After adding the 'bin' directory with the contents, it worked but did not have css.
    I am now installing from the beginning. the updates probably need to be improved.
    A few days ago I asked for github and here for adding polish and how to add translation and updates.

    I will give you the easy version, download this file: https://github.com/usmannasir/cyberpanel/blob/v1.7.1-dev/locale/id/LC_MESSAGES/django.po

    Edit this file via any editor, recommended is poedit. Once done you can send this file via private message or ticket.
    I have already been translated in most cases. I also found * .py * .html files with no '{% trans "....." %}' markers inserted. I wanted to report it. I'm using 'msgunfmt' 'msgunfmt'.
    In the new version, I often get errors:
    [Errno 2] No such file or directory: u'/home/cyberpanel/8567'
    [Errno 2] No such file or directory: u'/home/cyberpanel/9484'
    Virtual Host Directory already exists. [404]
  • > @ricardofh said:
    > Nope..
    >
    > [12-25-20-Mon-Aug-2018] #########################################################################
    >
    > [12-25-20-Mon-Aug-2018] You can not upgrade to v1.7.1 via automatic upgrade.
    >
    > [12-25-20-Mon-Aug-2018] #########################################################################
    >
    > so we won't be able to install 1.7.1 why? I was so happy when saw the features

    I will finalize the upgrade code this week for v1.7.0
  • > @Nencio said:
    > CyberPanel has stopped working. After adding the 'bin' directory with the contents, it worked but did not have css.
    > I am now installing from the beginning. the updates probably need to be improved.
    > A few days ago I asked for github and here for adding polish and how to add translation and updates.
    >
    > I will give you the easy version, download this file: https://github.com/usmannasir/cyberpanel/blob/v1.7.1-dev/locale/id/LC_MESSAGES/django.po
    >
    > Edit this file via any editor, recommended is poedit. Once done you can send this file via private message or ticket.
    >
    > I have already been translated in most cases. I also found * .py * .html files with no '{% trans "....." %}' markers inserted. I wanted to report it. I'm using 'msgunfmt' 'msgunfmt'.
    > In the new version, I often get errors:
    > [Errno 2] No such file or directory: u'/home/cyberpanel/8567'
    > [Errno 2] No such file or directory: u'/home/cyberpanel/9484'
    > Virtual Host Directory already exists. [404]

    Send me your updated .po file.
  • edited August 20
    I'll check with today's update and I'll send you updated with it.
    Only here I do not have permission to send attachments in PM like using the forum code.
  • For now, upgrade does not run for your version, did you tried restarting gunicorn socket?

    systemctl restart gunicorn.socket
    I have the 1.7 can i upgrade manually to the 1.7.1?
  • How can I install cyberpanel 1.7.1 new ?

  • I will finalize the upgrade code this week for v1.7.0

    Does this mean that 7.0 will get this features through standard upgrade procedure?

    I'm wishing to take advantage of the ACL features in 7.1
  • > @daniel said:
    > I will finalize the upgrade code this week for v1.7.0
    >
    > Does this mean that 7.0 will get this features through standard upgrade procedure?
    >
    > I'm wishing to take advantage of the ACL features in 7.1

    Daniel you can upgrade now using the official upgrade guide, feel free to get back if you run into any issues.
  • How to upgrade to the latest version? In the Overview - Version Management, there is no button to upgrade CyberPanel.

    SS: http://prntscr.com/kohewv

    or I should upgrade it manualy with terminal?
  • aris said:

    How to upgrade to the latest version? In the Overview - Version Management, there is no button to upgrade CyberPanel.

    SS: http://prntscr.com/kohewv

    or I should upgrade it manualy with terminal?

    https://docs.cyberpanel.net/doku.php?id=upgrade
  • > @daniel said:

    > I will finalize the upgrade code this week for v1.7.0

    >

    > Does this mean that 7.0 will get this features through standard upgrade procedure?

    >

    > I'm wishing to take advantage of the ACL features in 7.1



    Daniel you can upgrade now using the official upgrade guide, feel free to get back if you run into any issues.

    All good on the upgrade thank you.

    I did get some errors along the way:
    ERROR 1075 (42000) at line 1: Incorrect table definition; there can be only one auto column and it must be defined as a key

    and

    ?: (mysql.W002) MySQL Strict Mode is not set for database connection 'default'


  • daniel said:

    > @daniel said:

    > I will finalize the upgrade code this week for v1.7.0

    >

    > Does this mean that 7.0 will get this features through standard upgrade procedure?

    >

    > I'm wishing to take advantage of the ACL features in 7.1



    Daniel you can upgrade now using the official upgrade guide, feel free to get back if you run into any issues.

    All good on the upgrade thank you.

    I did get some errors along the way:
    ERROR 1075 (42000) at line 1: Incorrect table definition; there can be only one auto column and it must be defined as a key

    and

    ?: (mysql.W002) MySQL Strict Mode is not set for database connection 'default'


    How did you solve the errors, or did you leave it that way?
  • On which page do you get this error?
  • I tried to upgrade Cyberpanel using:

    cd
    rm -rf upgrade.py
    wget http://cyberpanel.net/upgrade.py
    python upgrade.py

    Got this error messages. What am I doing wrong?


    python upgrade.py
    Traceback (most recent call last):
    File "upgrade.py", line 654, in
    Upgrade.upgrade()
    File "upgrade.py", line 584, in upgrade
    Version = version.objects.get(pk=1)
    File "/usr/lib64/python2.7/site-packages/django/db/models/manager.py", line 85, in manager_method
    return getattr(self.get_queryset(), name)(*args, **kwargs)
    File "/usr/lib64/python2.7/site-packages/django/db/models/query.py", line 379, in get
    self.model._meta.object_name
    baseTemplate.models.DoesNotExist: version matching query does not exist.
  • On Version Management I get:
    Current Version
    1.7
    Build
    1
    Latest Version
    1.7
    Latest Build
    2 - in red

    But there's no option do upgrade.
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!