Problem with Domain & CloudFlare

KHRKHR
edited September 13 in DNS Server
I have installed CyberPanel on Amazon Lightsail (4 GB RAM, 2 vCPUs). All the necessary ports are open from Amazon and CyberPanel. I have installed WP. I using CloudFlare DNS, but I can't access to site using Domain.

When I setup DNS and CDN on CloudFlare site is not accessible but returning to Error 502 (Bad gateway). Firewall Screenshots: https://i.imgur.com/AHJSDXh.jpg

Now what is the Problem? How to fix it?
Tagged:
Tagged:

Comments

  • is it accessible without CF proxy ?
  • qtwrk said:

    is it accessible without CF proxy ?

    Some times.
  • I figured out the Problem, It's SSL issue, when I enabled Full SSL on CloudFlare, It's returning to 502 Error page, because SSL is not installed on Origin Sever.

    But I installed SSL using CyberPanel, I also reissued few times for fixing the Issue. That means CyberPanel actually not installing SSL but showing the Success message. It's a bugs of CyberPanel that it's showing success message without installing SSL.

    How can I fix this Issue?
  • KHR said:

    I figured out the Problem, It's SSL issue, when I enabled Full SSL on CloudFlare, It's returning to 502 Error page, because SSL is not installed on Origin Sever.

    But I installed SSL using CyberPanel, I also reissued few times for fixing the Issue. That means CyberPanel actually not installing SSL but showing the Success message. It's a bugs of CyberPanel that it's showing success message without installing SSL.

    How can I fix this Issue?

    What does CyberPanel main log file says when you try to issue SSL?
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!