Lag, Long-running connections, timeouts

edited October 6 in Bug Report
Not sure why this is happening but it's causing my site to occasionally lag and timeout. I inspected htop and found that there are some PHP connetions and mysql processes running for a very long time: http://pix.toile-libre.org/upload/original/1538840762.png

Even though max execution time and all that are set to low amount of seconds. PHP info: https://bit.ly/2OIpXFQ

Comments

  • Here is something that keeps showing up in my error log. I am also using the lsws wordpress cache plugin:

    2018-10-06 15:47:52.373260 [INFO] [141.101.77.254:45048] HttpExtConnector state: 8, request body sent: 0, response body size: -2, response body sent:649, left in buffer: 0, attempts: 0.
    2018-10-06 15:47:54.106749 [INFO] [162.158.123.115:64726] Connection idle time too long: 301 while in state: 6 watching for event: 24, close!
    2018-10-06 15:47:54.106775 [INFO] [162.158.123.115:64726] Content len: 109, Request line:
    POST /wp-admin/admin-ajax.php?_fs_blog_admin=true HTTP/1.1
    2018-10-06 15:47:54.106781 [INFO] [162.158.123.115:64726] HttpExtConnector state: 8, request body sent: 109, response body size: -2, response body sent:649, left in buffer: 0, attempts: 0.
  • That script in the proc list should never run for that long. it was not under apache
  • Maybe PHP is not responding to OpenLiteSpeed, could be a possible bug with OpenLiteSpeed. You can submit a ticket here so it can be further checked https://store.litespeedtech.com/store/contact.php
  • Strange. It's not happening now. I turned on Smart-KeepAlive and setup IP forwarding with CloudFlare + Client IP in Header. Magically there are no orphans now so no need for ticket. Will keep an eye on it. Thanks.
  • This came up again, badly. had to submit a ticket.
Sign In or Register to comment.
Support CyberPanel CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!