7080 not available after some time - how can I debug? — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberHosting

7080 not available after some time - how can I debug?

The server has 4 cores and 8 GB RAM, about 10 Joomla sites, different versions, 3-4 of them with lscache plugins. PowerDNS, Postfix, FTP, CSF and modsecurity are enabled.

After sometime OLS is not accessible at 7080 port. I can access CP on 8090 and restart it, so it is functional again.

What can be the reason? Where should I look?

Comments

  • The Chrome error is
    ```
    This site can't be reached
    ... took too long to respond.
    ```
  • You have to add port 7080 to csf (ipv4 port settings) then restart csf for some reason it is not incuded as default.
  • I already opened 7080 port in CSF and it is accessible (for some time).
    It was the first thing I did during setup. It is needed (for me) for (1) learning (2) fine-tuning (3) detailed inspection of connections during testing. I may close it afterwards. CP does not replicate OLS panel (it shouldn't).

    The problem is: it becomes inaccessible after some time - a rather random period.
    I read about "number of open files" problem in multiple places, did some touches but I don't know what to look to debug.
  • This was already documented in OLS KB, I found it yesterday night.

    https://openlitespeed.org/kb/too-many-open-files-errors-how-to-increase-the-operating-system-file-descriptor-limit/

    I doubled the first limit (ulimit) from 65535 but it happened again. I need to experiment on it examining the logs in realtime before asking in OLS forums. Probably I'll need to use Apache load test - one more sleepless night :(

    Thank you for redirect @hennaboy :)
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion