Error adding sftp backup destination — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

Error adding sftp backup destination

I am getting this error when trying to add a sftp backup destination:

Host xx.xx.xx.xx not found in /root/.ssh/known_hosts
Wrong Password!

I do see the ssh key under the file /root/.ssh/known_hosts

I can ssh to the destination server with the sftp user/password.
I have also tried cleaning the known_hosts file content. IP of the both servers are added to csf of both servers.

Both servers are running cyberpanel on centos 7

Virtualization Type: KVM VPS

System: Centos 7.9

OLS or Enterprise?

Installing from official server or mirror server?
Domain Registration Bangladesh
Web Hosting Bangladesh


  • I was using the user created with "website > ssh access ". (over destivation vps wich is also running on cyberpanel)

    I now tried using the root user and was able to add the destination.

    So the issue seems to be with the ssh user created from web site interface?
    Domain Registration Bangladesh
    Web Hosting Bangladesh
  • Hello, i have the same Problem. Can u explain how u did that?
  • Hello. I have the same problem. i can access server from ssh. i also have access without password by using ssh-copy-id.
    but "wrong password" message will show when i trying to add remote destination
  • I have the same issue. After testing a lot I figured out the problem, but unfortunally have no solution.

    If you add a new backup destination and choose SFTP you can enter :smile:

    IP Address

    Unfortunally every try I did ends with "wrong password". After study logfiles on Server and destination I figured out, that the given username is completely ignored!

    Backup trys ever with username "root" and ignores the entered username.

    This is a big bug! Most professional backup destinations are only usable with a username. You never ever get the "root" account.

    So please: Fix it!

    Best regards,
  • Hi

    I have the same issue adding a sftp backup destination ignores the username and only submits root as the username. Would you also add the ability to use a non root user for the sftp incremental backup destinations. Hacking around this is a bit of a mission and should be easy to fix.

Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!