Wordpress: Installation failed. Error message: [404] — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

Wordpress: Installation failed. Error message: [404]

Provider: Linode

Virtualization Type: Linode - Shared CPU Nanode 1GB

System: Ubuntu 20.04 LTS

Installation option: Distribuiton - Ubuntu 20.04 LTS

OLS or Enterprise?
OLS

Installing from official server or mirror server?
Official

Install Memcached extension for PHP?
Yes

Install LiteSpeed Memcached?
Yes

Install Memcached?
Yes

Install Redis extension for PHP?
Yes

Install Redis?
Yes


Problem:

I have created a package and a website, but when I try install WordPress on it from CyberPanel, it fails and show error message "Installation failed. Error message: [404]".

I tried re-install on clean Ubuntu 20.04 LTS but still happens.

I have tested on DigitalOcean and it works, but I want use Linode because I need run a mail server.

Could you please help me?

Thank you in advance.


Best regards,
Dany Coutinho

Comments

  • Hi. I can´t help you, but had similar Problems after migrating Websites to a new installed Server with Cyberpanel. After a lot of testing I figured out that my problem was caused from mod_security I acivated,

    So my hint: Try to deactivate mod-Security under the "Security" panel complete and try again your install.

    Best regards,
    Kai
  • I am facing the same issue...
  • edited April 26
    same here :(
  • same here, any fix?
  • What is content of your my.cnf ?
  • Type your comment> @usmannasir said:
    > What is content of your my.cnf ?

    i just optimized it from cloud still nothing i get this error on every installable thing
    It makes the folder and database what i gave it but the folder is empty this is my only problem with cyberpanel
  • But what is current content of my.cnf?
  • https://pastebin.com/NjuwVdqC
    This is the one before the optimalization bc wit the optimized it wouldnt let me login 😅
  • https://cyberpanel.net/docs/troubleshooting-cyberpanel/

    Read under "Improved and detailed dynamic logging"

    Once enabled install WordPress and share logs.
  • Thanks now i think i know why it isn't working its the wp command, wp core download does nothing basically nothing if i ran it manually nothing happens no error no progress
    But this doesn't help me why i cant install joomla either
    error log, myqsl passwords removed https://pastebin.com/PTbMKcVT
  • For Joomla please create separate thread, kindly keep this to WordPress only. So wp cli is not installed or not working?

    You can run this command to test via cli

    sudo -u bazsi7767 wp core download --allow-root --path=/home/bazsi15.hu/public_html//wp-test3/
  • I got same issue.
    Log file

    [05.13.2021_02-06-58] JR6AXUEMozMhuJgUWK7bDIY3BGbOojxysudo chmod 750 /home/test.hubhotel.com.tw/public_html
    [05.13.2021_02-06-58] JR6AXUEMozMhuJgUWK7bDIY3BGbOojxysudo rm -rf /var/lib/mysql/AWyurVjYMD2E1p/.git
    [05.13.2021_02-06-58] Expecting value: line 1 column 1 (char 0). [setupConnection:75]
    [05.13.2021_02-06-58] JR6AXUEMozMhuJgUWK7bDIY3BGbOojxysudo cat /home/cyberpanel/4027
  • Show complete logs please.
  • Same problem here. A lot of people having this problem...
  • I had the same Wordpress install issues and for me it was 2 things on my fresh Cyberpanel install on Ubuntu 20.04:

    1. wp-cli was not installed. I installed it manually and everything went 1 step further during a wordpress install. Then..
    2. After turning on debug logging in Cyberpanel I noticed that I didn't have the mysql extension installed for php. Which obviously was untrue. Sort of... Litespeed obviously makes uses of lsphp binaries and not the native ones that would be installed on Ubuntu. Cyberpanel just runs "php" to access the php-cli. According to the native php-cli on Ubuntu there is indeed no mysql extension. You could simply install the extension but I just recreated the symlink for /usr/bin/php to point to /usr/local/lsws/lsphp74/bin/php and that sorted it out.

    I don't know why wp-cli wasn't installed with Cyberpanel. I followed the Cyberpanel install instructions. Maybe the 2.1.1 version has a bug in that regard? It may be worth simply updating the native php install to include the same modules that installed by default with lsphp just to avoid these sort of problems in the future? Or have Cyberpanel explicitly use lsphp for anything it needs php-wise.
  • I usually solve this type of problem by changing the PHP version to any other and then returning to the version it was. Try this to see if it works.
  • I got same problem. this is my log

    [07.17.2021_02-59-30] Successfully obtained SSL for: kitchen.hubhotel.com.tw
    [07.17.2021_02-59-30] /usr/local/lsws/bin/lswsctrl restart
    [07.17.2021_03-05-20] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo chown -R cyberpanel:cyberpanel /home/cyberpanel
    [07.17.2021_03-05-20] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo wp --info
    [07.17.2021_03-05-20] Expecting value: line 1 column 1 (char 0). [setupConnection:75]
    [07.17.2021_03-05-20] CREATE DATABASE 1xrMLr8ThxzXWK
    [07.17.2021_03-05-20] CREATE USER '1xrMLr8ThxzXWK'@'localhost' IDENTIFIED BY 'Ek8rc7DoN1Unac'
    [07.17.2021_03-05-20] GRANT ALL PRIVILEGES ON 1xrMLr8ThxzXWK.* TO '1xrMLr8ThxzXWK'@'localhost'
    [07.17.2021_03-05-20] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo chmod 755 /home/kitchen.hubhotel.com.tw/public_html
    [07.17.2021_03-05-20] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjI-u kitch8022 wp core download --allow-root --path=/home/kitchen.hubhotel.com.tw/public_html/
    [07.17.2021_03-05-22] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo cat /home/cyberpanel/7993
    [07.17.2021_03-05-23] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo cat /home/cyberpanel/7993
    [07.17.2021_03-05-24] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo cat /home/cyberpanel/7993
    [07.17.2021_03-05-25] Downloading WordPress 5.7.2 (en_US)...
    md5 hash verified: 5493c7abf5317889af2bcd885d352823
    Success: WordPress downloaded.

    [07.17.2021_03-05-25] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjI-u kitch8022 wp core config --dbname=1xrMLr8ThxzXWK --dbuser=1xrMLr8ThxzXWK --dbpass=Ek8rc7DoN1Unac --dbhost=localhost:3306 --dbprefix=wp_ --allow-root --path=/home/kitchen.hubhotel.com.tw/public_html/
    [07.17.2021_03-05-25] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo cat /home/cyberpanel/7993
    [07.17.2021_03-05-27] Success: Generated 'wp-config.php' file.

    [07.17.2021_03-05-27] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjI-u kitch8022 wp core install --url="http://kitchen.hubhotel.com.tw" --title="[07.17.2021_03-05-27] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo cat /home/cyberpanel/7993
    [07.17.2021_03-05-28] Error: Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    [07.17.2021_03-05-28] N7Q5xJ4/RlbBxKwe3KtwY5eiYBG36UjIsudo cat /home/cyberpanel/7993
  • Fixed it with this command on ubuntu

    sudo apt-get install php-mysql
  • Type your comment> @Josh said:
    > Fixed it with this command on ubuntu
    >
    > sudo apt-get install php-mysql

    This worked for me.
  • Type your comment> @usmannasir said:
    > https://cyberpanel.net/docs/troubleshooting-cyberpanel/
    >
    > Read under "Improved and detailed dynamic logging"
    >
    > Once enabled install WordPress and share logs.

    @usmannasir
    Wordpress installation failing with 404 error for any website.
    Here is what detailed debug log says:
    ERROR 1045 (28000): Access denied for user '0slvyfBOLQAjvz'@'127.0.0.1' (using password: YES)

    ## my.cnf
    [mysqld]
    bind-address=localhost
    bind-address=127.0.0.1
    skip-name-resolve
    log-error=/var/log/mysqld.log
    max_allowed_packet=16M
    innodb_buffer_pool_size=1G
    #tokudb_cache_size=1G
  • same issue here as @vpsingh . did you manage to get it sorted?

    I ended up installing the WP manually...
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!