I can recieve emails but not send — CyberPanel - WebHosting Control Panel for OpenLiteSpeed
CyberLoader

I can recieve emails but not send

Hello,

If I try to send an email using rainloop, It does not make into inbox nor spam.
If someone sends an email to me, I can read that email in rainloop inbox, but even if I reply to that email. Other user cannot see the reply.

Basically, I am receiving emails but not able to send back.

I did a mistake and made an email in mail.domain.com instead of domain.com while creating email. Now I am unable to delete it. Can that be the reason for it ?

Also, If I try to use POP3 and connect with gmail, I get error "Cannot connect to mail.domain.com"

Any fix to it ? Looking forward to a reply!

Thanks in advance!

Comments

  • Please check https://forums.cyberpanel.net/discussion/5384/cant-send-or-receive-e-mail

    There of many topics related to email in the forum. You can debug and find your cause.
  • Type your comment> @usmannasir said:
    > Please check https://forums.cyberpanel.net/discussion/5384/cant-send-or-receive-e-mail
    >
    > There of many topics related to email in the forum. You can debug and find your cause.

    Thank you for your reply!

    I thoroughly read but I couldn't find the a fix.

    Please note that I can actually receive emails via cyberpanel webmail when I send from gmail(or any other)

    But When I send email from cyberpanel webmail, Webmail says they're sent, But I cannot see them in my gmail account.

    Also I want to add that I am using Amazon EC2 instance,
    But I confirmed that port 25 is open and not closed.

    Looking forward to your reply!
    Thanks!
  • Ok, please share logs using the guide above.
  • Type your comment> @usmannasir said:
    > Ok, please share logs using the guide above.

    Sorry For late Reply! I will try to be quick next time.

    Here is the log you must be looking for!

    May 04 00:09:32 ip-172-31-32-67 postfix/submission/smtpd[118262]: connect from localhost[127.0.0.1]
    May 04 00:09:32 ip-172-31-32-67 postfix/submission/smtpd[118262]: TLS SNI localhost from localhost[127.0.0.1] not matched, using default chain
    May 04 00:09:32 ip-172-31-32-67 postfix/submission/smtpd[118262]: C13CF7F895: client=localhost[127.0.0.1], sasl_method=PLAIN, [email protected]
    May 04 00:09:32 ip-172-31-32-67 postfix/submission/smtpd[118262]: warning: connect to /var/log/policyServerSocket: No such file or directory
    May 04 00:09:33 ip-172-31-32-67 postfix/submission/smtpd[118262]: warning: connect to /var/log/policyServerSocket: No such file or directory
    May 04 00:09:33 ip-172-31-32-67 postfix/submission/smtpd[118262]: warning: problem talking to server /var/log/policyServerSocket: No such file or directory
    May 04 00:09:33 ip-172-31-32-67 postfix/cleanup[118265]: C13CF7F895: message-id=<[email protected]>
    May 04 00:09:33 ip-172-31-32-67 postfix/qmgr[87181]: C13CF7F895: from=<[email protected]>, size=1305, nrcpt=1 (queue active)
    May 04 00:09:33 ip-172-31-32-67 postfix/submission/smtpd[118262]: disconnect from localhost[127.0.0.1] ehlo=2 starttls=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=8
    May 04 00:09:33 ip-172-31-32-67 postfix/smtp[118268]: connect to gmail-smtp-in.l.google.com[2404:6800:4003:c00::1b]:25: Network is unreachable
    May 04 00:10:03 ip-172-31-32-67 postfix/smtp[118268]: connect to gmail-smtp-in.l.google.com[74.125.200.26]:25: Connection timed out
  • May 04 00:10:03 ip-172-31-32-67 postfix/smtp[118268]: connect to gmail-smtp-in.l.google.com[74.125.200.26]:25: Connection timed out

    Port blocked, contact your provider.
  • Most of the providers block the SMTP ports. I was able to work around it by using SENDGRId and integrating it. It works just fine now :) bit of a hassle to open an account on sendgrid everytime i open a new domain, but nothing we can do unless the hosts fix it. :)
  • Type your comment> @usmannasir said:
    > May 04 00:10:03 ip-172-31-32-67 postfix/smtp[118268]: connect to gmail-smtp-in.l.google.com[74.125.200.26]:25: Connection timed out
    >
    > Port blocked, contact your provider.

    Apologies!

    I tried Telnet (mailserver) 25 to check if port 25 was blocked or not.

    And If it was blocked; I must had gotten an error but it opened a new tab successfully. (You can check ss).

    https://i.imgur.com/21z6pM6.png

    That is the reason why I said above that Port 25 is not blocked.

    I will contact AWS customer support now. Thanks for your time and assistance :)
  • > @slimx said:
    > Most of the providers block the SMTP ports. I was able to work around it by using SENDGRId and integrating it. It works just fine now :) bit of a hassle to open an account on sendgrid everytime i open a new domain, but nothing we can do unless the hosts fix it. :)

    wow! I'm happy to hear you found a fix :)

    I will look into Sendgrid if AwS doesn't resolve the issue for me ...

    Thanks allot for letting me know. I had no idea about an alternate way :)

    Let's hope for best!
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!