Docker is not working anymore with fresh new install — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

Docker is not working anymore with fresh new install

I need help with docker ... I actually want to use docker but after fresh install of CyberPanel when I click docker it says docker is not installing and give me Button to install, so I click there to install docker from my CyberPanel Dashboard , but after installing its giving me warning that "" Unable to connect docker daemon, please try restarting docker from service page" but i tried that also from Service page but when I click Start nothing happened .... i tried in both Centos 7 and Ubuntu VPS Server but same results, then I tried to restart docker using command # systemctl start docker from ssh but again getting another warning "Job for docker.service canceled."

then this command also # systemctl status docker.service

and got this :

[[email protected] ~]# systemctl status docker.service
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2019-10-21 20:10:15 CEST; 1min 56s ago
Process: 737674 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=205/LIMITS)
Main PID: 737674 (code=exited, status=205/LIMITS)

Oct 21 20:10:15 systemd[1]: Starting Docker Application Container Engine...
Oct 21 20:10:15 systemd[1]: docker.service: main process exited, code=exited, status=205/LIMITS
Oct 21 20:10:15 systemd[1]: Stopped Docker Application Container Engine.
Oct 21 20:10:15 systemd[1]: Unit docker.service entered failed state.
Oct 21 20:10:15 systemd[1]: docker.service failed.

I tried many times even reinstalling vps server again and again but the same results everytime ....


  • I'm having the same problem.

    Installed CyberPanel using Digital Ocean's one-click installer. Docker won't start because containerd won't start. The containerd errors with:

    Oct 23 17:36:55 cyberpanel systemd[7030]: containerd.service: Failed to adjust resource limit LimitNOFILE: Operation not permitted
    Oct 23 17:36:55 cyberpanel systemd[7030]: containerd.service: Failed at step LIMITS spawning /sbin/modprobe: Operation not permitted
  • Is it OpenVZ?

    No, This is KVM and to inform you that I have tried Digitalocean , Vultr also but got the same problem every time with a fresh install of CyberPanel

    I am wondering why nobody facing the issue Or they did not interested in Docker so they are not giving try installing docker so they don't know that this is a problem.
  • any news on how to fix this?
  • I will take a look and get back soon.
  • I will take a look and get back soon.

    Waiting for your response on docker issue
  • Please change the entry in:
    systemctl restart docker.service
    And check if it works.
  • Hi!
    This problem also exists for me. Im just a new Digitalocean User, and I can not migrate my docker environment, since Docker on CyberPanel fails to launch.
    This happens for docker-ce which comes with cyberpanel as well with manual tried docker-ee in both cases systems is reporting error:205/Limits.

    The upper workaround from Nencio didn't work for me.
    In /etc/systemd/system/
    there is no LimitNOFILE=1048576 nor LimitNOFILE=ulimit
    its called LimitNOFILE=infinity.
    However I have tried with both lines Nencio is menting, but the error message is not changing at all.
    Of course I did systemctl restart docker.service after changing the systemd file.

    Would be cool if someone finds and share a solution for this docker problem. I really like CyberPanel and would be a pain to look for an alternative backend, just to this minor error. :(

    Best Regards!
  • I did not want to work after installing CyberPanel and installing it by Docker.
    I changed to such settings and it started working:
    [Unit] Description=Docker Application Container Engine Documentation= Wants=docker-storage-setup.service Requires=docker-cleanup.timer [Service] Type=notify NotifyAccess=main EnvironmentFile=-/run/containers/registries.conf EnvironmentFile=-/etc/sysconfig/docker EnvironmentFile=-/etc/sysconfig/docker-storage EnvironmentFile=-/etc/sysconfig/docker-network Environment=GOTRACEBACK=crash Environment=DOCKER_HTTP_HOST_COMPAT=1 Environment=PATH=/usr/libexec/docker:/usr/bin:/usr/sbin ExecStart=/usr/bin/dockerd-current \ --add-runtime docker-runc=/usr/libexec/docker/docker-runc-current \ --default-runtime=docker-runc \ --exec-opt native.cgroupdriver=systemd \ --userland-proxy-path=/usr/libexec/docker/docker-proxy-current \ --init-path=/usr/libexec/docker/docker-init-current \ --seccomp-profile=/etc/docker/seccomp.json \ $OPTIONS \ $DOCKER_STORAGE_OPTIONS \ $DOCKER_NETWORK_OPTIONS \ $ADD_REGISTRY \ $BLOCK_REGISTRY \ $INSECURE_REGISTRY \ $REGISTRIES ExecReload=/bin/kill -s HUP $MAINPID #LimitNOFILE=1048576 LimitNOFILE=ulimit LimitNPROC=1048576 LimitCORE=infinity TimeoutStartSec=0 Restart=on-abnormal KillMode=process [Install]
  • edited November 2019
    Hi again!

    This modified systems-file won't do its job either for me. :(

    ..starting from scratch I have tried to troubleshoot this myself now, and well. I did have success :)

    Actually Nencio's first posted guess was correct if you mention this litte but essential difference:

    I assume by mistake in the rush, Nenico just quoted a wrong file-location of the systemd-file which needs edited:
    Nencio said:

    Please change the entry in:

    But the correct one file is:
    Please note the .service

    ..There is now expected line LimitNOFILE=1048576 which needs to be edited into
    LimitNOFILE=ulimit -n

    followed by
    systemctl daemon-reload
    systemctl restart docker.service
    the Docker service is now running and manageable through CyberPanel. Yay.

    Nenico thanks for investigating and help. For me its solved. :)

  • It depends on the system. I have CyberPanel installed on Centos and a docker installed in CyberPanel. It works with and without the -n option.
Sign In or Register to comment.
CyberPanel Discord

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!